TinTin++ Mud Client The TinTin++ message board

 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
TinTin++ Mud Client

TinTin++ 1.99.0

 
Post new topic   This topic is locked: you cannot edit posts or make replies.    The TinTin++ message board Forum Index -> Announcements
View previous topic :: View next topic  
Author Message
Scandum
Site Admin


Joined: 03 Dec 2004
Posts: 3770

PostPosted: Sun Feb 15, 2009 10:49 pm    Post subject: TinTin++ 1.99.0 Reply with quote


  • #showme and #echo now take a // as a suffix to stop a linefeed from being added.

  • Added an extra measure to prevent losing track of the cursor position.

  • Added an END OF PATH event.

  • #debug should give more detailed debugging information for triggers.

  • Removed timestamp config option, a scripted #event based alternative has been added to the SCRIPT file. (Trying to avoid feature bloat as much as possible.)

  • Added support for auto tab completion based on the scroll back buffer.

  • Added auto tab config option to set the amount of scroll back lines used for auto tab completion.
Back to top
View user's profile Send private message Send e-mail
murlyn



Joined: 17 Sep 2007
Posts: 27

PostPosted: Mon Feb 16, 2009 12:14 pm    Post subject: Reply with quote

Awesome! Looks like using the directions neswduneeeen works again Smile

Now Im having another problem which in the meantime Im going to have to switch back to the old version. All lines sent to another window are now crashing tintin. This used to be what I had to log the line:


Code:
#alias {log} {#logline Edge/logs.tells}

#act {%0 tells you,} {#var tellperson %0;log}
#act {group-says} {log}
#act { says '} {log}
#act { shouts '} {log}
#act { gossips '} {log}
#act { auctions '} {log}


Now it just crashes. I tried changing logline to #line log {} that didn't work. Any ideas?
Back to top
View user's profile Send private message
Scandum
Site Admin


Joined: 03 Dec 2004
Posts: 3770

PostPosted: Mon Feb 16, 2009 1:53 pm    Post subject: Reply with quote

Doesn't crash for me. Could you try to narrow it down?
Back to top
View user's profile Send private message Send e-mail
murlyn



Joined: 17 Sep 2007
Posts: 27

PostPosted: Mon Feb 16, 2009 2:33 pm    Post subject: Reply with quote

Anything in particular that I can do to narrow it down? All I know is that when someone says something, or gossips or does anything that should send it to the other window, it crashes tintin.
Back to top
View user's profile Send private message
Scandum
Site Admin


Joined: 03 Dec 2004
Posts: 3770

PostPosted: Mon Feb 16, 2009 3:03 pm    Post subject: Reply with quote

Well, to narrow things down in this case:

What's your OS? Compiled or using a binary? If compiled did you do a clean compile?

Does it crash when you execute: #line log {bla} {x.log} ?
Back to top
View user's profile Send private message Send e-mail
Scandum
Site Admin


Joined: 03 Dec 2004
Posts: 3770

PostPosted: Mon Feb 16, 2009 3:31 pm    Post subject: Reply with quote

I found the bug, I updated wintin++, the osx / linux binary, and the source code on sourceforge.
Back to top
View user's profile Send private message Send e-mail
murlyn



Joined: 17 Sep 2007
Posts: 27

PostPosted: Mon Feb 16, 2009 5:37 pm    Post subject: Reply with quote

Ah sweet, thanks. I am using OSX binary. Ill update then. Thanks again! Smile
Back to top
View user's profile Send private message
Scandum
Site Admin


Joined: 03 Dec 2004
Posts: 3770

PostPosted: Mon Feb 16, 2009 7:07 pm    Post subject: Reply with quote

You're welcome, and thanks for letting me know about this so quickly. Smile
Back to top
View user's profile Send private message Send e-mail
murlyn



Joined: 17 Sep 2007
Posts: 27

PostPosted: Wed Feb 18, 2009 3:08 am    Post subject: Reply with quote

I updated today and I got this debug dump, completely freaked me out when it happened Smile I had just killed a mob and my loot trigger was going to go off, but got this dump. Any ideas what caused it?

Code:
###############################################################################################
######################################### DEBUG STACK #########################################
DEBUG_STACK[000] = show_debug(0x85000,0x13,0x3f8d4)
DEBUG_STACK[001] = show_debug(0xad000,0x13,0x3f8d4)
DEBUG_STACK[002] = show_debug(0xad000,0x13,0x3f8d4)
DEBUG_STACK[003] = show_debug(0xad000,0x13,0x3f8d4)
DEBUG_STACK[004] = show_debug(0xad000,0x13,0x3f8d4)
DEBUG_STACK[005] = readmud(0xad000)
DEBUG_STACK[006] = readmud(0xad000)
DEBUG_STACK[007] = [Edge] do_one_line(Last player logged on: Froog at Tue Feb 17 20:50:10 2009
(EST))
DEBUG_STACK[008] = [Edge] do_one_line(Saving Mikael.)
DEBUG_STACK[009] = show_debug(0xad000,0x0,0x2b838)
DEBUG_STACK[010] = parse_input(Edge,load Mikael)
DEBUG_STACK[011] = show_debug(0xad000,0x1,0x2b898)
DEBUG_STACK[012] = show_debug(0xad000,0x13,0x3f8d4)
DEBUG_STACK[013] = show_debug(0xad000,0x13,0x3f8d4)
DEBUG_STACK[014] = show_debug(0xad000,0x13,0x3f8d4)
DEBUG_STACK[015] = show_debug(0xad000,0x13,0x3f8d4)
DEBUG_STACK[016] = show_debug(0xad000,0x13,0x3f8d4)
DEBUG_STACK[017] = readmud(0xad000)
DEBUG_STACK[018] = readmud(0xad000)
DEBUG_STACK[019] = readmud(0xad000)
DEBUG_STACK[020] = readmud(0xad000)
DEBUG_STACK[021] = readmud(0xad000)
DEBUG_STACK[022] = readmud(0xad000)
DEBUG_STACK[023] = readmud(0xad000)
DEBUG_STACK[024] = readmud(0xad000)
DEBUG_STACK[025] = readmud(0xad000)
DEBUG_STACK[026] = readmud(0xad000)
DEBUG_STACK[027] = readmud(0xad000)
DEBUG_STACK[028] = [Edge] do_one_line(The Gods have forced you to 'save'.)
DEBUG_STACK[029] = show_debug(0xad000,0x0,0x2b838)
DEBUG_STACK[030] = readmud(0xad000)
DEBUG_STACK[031] = readmud(0xad000)
DEBUG_STACK[032] = readmud(0xad000)
DEBUG_STACK[033] = [Edge] do_one_line(Draxus tells you, 'hey (;')
DEBUG_STACK[034] = show_debug(0xad000,0x0,0x2b838)
DEBUG_STACK[035] = show_debug(0xad000,0x13,0x3f8d4)
DEBUG_STACK[036] = readmud(0xad000)
DEBUG_STACK[037] = [Edge] do_one_line(Tevez gossips 'Hi Mik !')
DEBUG_STACK[038] = show_debug(0xad000,0x0,0x2b838)
DEBUG_STACK[039] = readmud(0xad000)
DEBUG_STACK[040] = readmud(0xad000)
DEBUG_STACK[041] = readmud(0xad000)
DEBUG_STACK[042] = readmud(0xad000)
DEBUG_STACK[043] = readmud(0xad000)
DEBUG_STACK[044] = readmud(0xad000)
DEBUG_STACK[045] = parse_input(Edge,od e)
DEBUG_STACK[046] = readmud(0xad000)
DEBUG_STACK[047] = readmud(0xad000)
DEBUG_STACK[048] = readmud(0xad000)
DEBUG_STACK[049] = readmud(0xad000)
DEBUG_STACK[050] = readmud(0xad000)
Back to top
View user's profile Send private message
Scandum
Site Admin


Joined: 03 Dec 2004
Posts: 3770

PostPosted: Wed Feb 18, 2009 10:50 am    Post subject: Reply with quote

It's an error in the debug stack that triggers after 10.000 calls to show_debug.

I think it's pretty harmless, for once it triggers it shouldn't trigger again, so you could use: #alias nop #nop;#10000 nop, when starting tintin to get it over with.

I've fixed it for the next release. Thanks for letting me know.
Back to top
View user's profile Send private message Send e-mail
murlyn



Joined: 17 Sep 2007
Posts: 27

PostPosted: Wed Feb 18, 2009 12:35 pm    Post subject: Reply with quote

Ah ok, because any command I put in after that triggered it to happen, I finally zapped the session and started over.
Back to top
View user's profile Send private message
Scandum
Site Admin


Joined: 03 Dec 2004
Posts: 3770

PostPosted: Wed Feb 18, 2009 12:42 pm    Post subject: Reply with quote

When nearing 10.000 it will trigger a few times, but after that it should be alright.

Updated the beta file with a fix at: http://tintin.sf.net/download/tintin-beta.tar.gz
Back to top
View user's profile Send private message Send e-mail
murlyn



Joined: 17 Sep 2007
Posts: 27

PostPosted: Fri Feb 20, 2009 11:52 am    Post subject: Reply with quote

I have another question for you.. this used to work:

Code:
#act {ALARM!} {wa;st;d;#$learntimes $learnspell;u;rest;who};


But now it does not and I get this error:

Code:
#ERROR: #UNKNOWN TINTIN-COMMAND '1'.
Back to top
View user's profile Send private message
Scandum
Site Admin


Joined: 03 Dec 2004
Posts: 3770

PostPosted: Fri Feb 20, 2009 2:39 pm    Post subject: Reply with quote

My mistake, I updated the beta file with a fix.
Back to top
View user's profile Send private message Send e-mail
murlyn



Joined: 17 Sep 2007
Posts: 27

PostPosted: Fri Feb 20, 2009 5:00 pm    Post subject: Reply with quote

Ah ok, good to know it wasn't anything I did, or syntax changes etc, heh. Ok so is there an easy way to create an os x binary from that beta? Im a PHP guy, so this compiling stuff is a bit.. well out of my comfort zone, but willing to give it a go Smile
Back to top
View user's profile Send private message
Scandum
Site Admin


Joined: 03 Dec 2004
Posts: 3770

PostPosted: Fri Feb 20, 2009 5:58 pm    Post subject: Reply with quote

Someone wrote a walkthrough a while ago for compiling tintin on os x, it doesn't look too hard.

http://thoughton.co.uk/digitallife/weblog/2004/03/tintin_on_os_x.php
Back to top
View user's profile Send private message Send e-mail
murlyn



Joined: 17 Sep 2007
Posts: 27

PostPosted: Fri Feb 20, 2009 6:45 pm    Post subject: Reply with quote

Thanks again! Smile
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   This topic is locked: you cannot edit posts or make replies.    The TinTin++ message board Forum Index -> Announcements All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Get TinTin++ Mud Client at SourceForge.net. Fast, secure and Free Open Source software downloads Get TinTin++ Mud Client at SourceForge.net. Fast, secure and Free Open Source software downloads
TinTin++ Homepage

Powered by phpBB © 2001, 2002 phpBB Group