TinTin++ Mud Client The TinTin++ message board

 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
TinTin++ Mud Client

Problem with captures & color codes

 
Post new topic   Reply to topic    The TinTin++ message board Forum Index -> Bug Reports
View previous topic :: View next topic  
Author Message
LokiChaos



Joined: 27 Oct 2009
Posts: 61

PostPosted: Wed Jan 20, 2010 3:24 pm    Post subject: Problem with captures & color codes Reply with quote

I have the following trigger, it does trigger properly, and properly adds an entry to the log file, but it's eating the hi-intensity tags, making them normal colors.

#act {~^\e[1\;33m[ALLIED %d] %*}
{
#format {allycap} {%t %s <099>} {{%m-%d %H:%M:%S}} {%0};
#line log {$capPath[allianceTalk]} {$allycap};
#unvar allycap;
}

It seems to have been working up until I upgraded to 1.99.9
Back to top
View user's profile Send private message
Scandum
Site Admin


Joined: 03 Dec 2004
Posts: 3857

PostPosted: Wed Jan 20, 2010 4:06 pm    Post subject: Reply with quote

You could try removing the extra pair of braces around the date argument, though I'm not sure if that's the problem:

#format {allycap} {%t %s <099>} {%m-%d %H:%M:%S} {%0}

Another option is not to escape the semi-colon in the trigger.


Also I'm not exactly sure what you mean, does it strip the bright yellow ansi color code? Or does it display as brown?
Back to top
View user's profile Send private message Send e-mail
LokiChaos



Joined: 27 Oct 2009
Posts: 61

PostPosted: Wed Jan 20, 2010 8:13 pm    Post subject: Reply with quote

It displays it as brown, and ALL colors codes are stripped of their intensity in the log. So even if there are changes in colors in what's said on that channel, it is all low intensity, regardless of the intensity of triggering text.

Edit: I rolled back to 1.99.8 and it works fine.
Back to top
View user's profile Send private message
Scandum
Site Admin


Joined: 03 Dec 2004
Posts: 3857

PostPosted: Wed Jan 20, 2010 9:26 pm    Post subject: Reply with quote

Found the issue, and I fixed it in the beta code:

http://tintin.sf.net/download/tintin-beta.tar.gz

Thanks for reporting the bug!
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    The TinTin++ message board Forum Index -> Bug Reports All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Get TinTin++ Mud Client at SourceForge.net. Fast, secure and Free Open Source software downloads Get TinTin++ Mud Client at SourceForge.net. Fast, secure and Free Open Source software downloads
TinTin++ Homepage

Powered by phpBB © 2001, 2002 phpBB Group