TinTin++ Mud Client The TinTin++ message board

 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
TinTin++ Mud Client

Event not being triggered [big5]

 
Post new topic   Reply to topic    The TinTin++ message board Forum Index -> Bug Reports
View previous topic :: View next topic  
Author Message
steven



Joined: 22 May 2011
Posts: 24

PostPosted: Tue May 31, 2011 11:51 am    Post subject: Event not being triggered [big5] Reply with quote

I have set actions that help me to train some special force, the code is as below:

Code:

#class dazuo open
#act {^妳不斷吸入白霧,待得白霧吸盡,緩緩站起。$} {
  hp;
  #delay {1} {#showme {980479start dazuo}};
}

#act {^980479start dazuo$} {
  #if {$food[food] < 300 || $water[water] < 300} {
    serve;
    eat gao;
    drop gao;
    drink tang;
    drop tang;
  };
  #if {$qi[qi] > 10} {
    #unticker dazuowait;
    dazuo 10;
    save;
  } {
    #ti {dazuowait} {hp;save;#showme 妳不斷吸入白霧,待得白霧吸盡,緩緩站起。} {10};
  };

}
#class dazuo close


Only 60%-70% the #act {^妳不斷吸入白霧,待得白霧吸盡,緩緩站起。$} is being triggered.
I turned on #debug action on, and it seems the action is not triggered, and I am sure there is no obvious broken word.
I try to change the action as "#act {^妳不%*,%*,%*站起。$}" in order to escape some weird chinese word. But no success.

This happens to 2.00.6 and 2.00.6b.

This is my default.ini config file:
Code:

#CONFIG           {CHARSET} {BIG5}
#CONFIG           {BIG5}  {ON}
#CONFIG           {AUTO TAB}  {5000}
#CONFIG           {BUFFER SIZE}  {20000}
#CONFIG           {COMMAND COLOR}  {<078>}
#CONFIG           {COMMAND ECHO}  {OFF}
#CONFIG           {CONNECT RETRY}  {15}
#CONFIG           {HISTORY SIZE}  {1000}
#CONFIG           {LOG}  {RAW}
#CONFIG           {PACKET PATCH}  {0.50}
#CONFIG           {REPEAT CHAR}  {!}
#CONFIG           {REPEAT ENTER}  {OFF}
#CONFIG           {SCROLL LOCK}  {ON}
#CONFIG           {SPEEDWALK}  {OFF}
#CONFIG           {TINTIN CHAR}  {#}
#CONFIG           {VERBATIM}  {OFF}
#CONFIG           {VERBATIM CHAR}  {\}
#CONFIG           {VERBOSE}  {OFF}
#CONFIG           {WORDWRAP}  {ON}

#PATHDIR          {e}  {w}  {2}
#PATHDIR          {w}  {e}  {8}
#PATHDIR          {n}  {s}  {1}
#PATHDIR          {s}  {n}  {4}
#PATHDIR          {ne}  {sw}  {3}
#PATHDIR          {nw}  {se}  {9}
#PATHDIR          {se}  {nw}  {6}
#PATHDIR          {sw}  {ne}  {12}
#PATHDIR          {u}  {d}  {16}
#PATHDIR          {d}  {u}  {32}


Any tips?
Back to top
View user's profile Send private message
steven



Joined: 22 May 2011
Posts: 24

PostPosted: Tue May 31, 2011 1:27 pm    Post subject: Reply with quote

I temporarily resolve the problem by

changing the pattern as below: Cool
#act {^%.%.不斷吸入白霧,待得白霧吸盡,緩緩站起。$}

Seems the chinese character "妳 is difficult to be recognized ...
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    The TinTin++ message board Forum Index -> Bug Reports All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Get TinTin++ Mud Client at SourceForge.net. Fast, secure and Free Open Source software downloads Get TinTin++ Mud Client at SourceForge.net. Fast, secure and Free Open Source software downloads
TinTin++ Homepage

Powered by phpBB © 2001, 2002 phpBB Group