TinTin++ Mud Client The TinTin++ message board

 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
TinTin++ Mud Client

Big Problem

 
Post new topic   Reply to topic    The TinTin++ message board Forum Index -> Bug Reports
View previous topic :: View next topic  
Author Message
mleo2003



Joined: 01 Nov 2006
Posts: 21
Location: Mississippi

PostPosted: Mon Nov 06, 2006 4:51 pm    Post subject: Big Problem Reply with quote

I don't know if anyone else is having this issue too or not, mainly because it is such a big one for me, I figured someone else would have said something about it by now.

With the newest source (1.96.3), I can't enter two tintin commands on the same line:

Code:
#var Test 1; #var Test 2


All that does is set the variable to 1, but then sends the other to the mud literally, which always gets me a "Huh?" from the mud.

A lot of my scripts are now broke because of this. Two regular commands, like stand and sit, back to back work fine, it only does this with TinTin commands. If I put a look, or something else inbetween the TinTin stuff, everything works fine.

After a bit more testing, it's the space after the ; which seems to be throwing it off. I.E., "#var Test 1;#var Test 2" works like a charm.

I recompiled the 1.96.2 source, and that is no longer a problem, so it has to be something added lately. No clue what (I knew to do a diff on the two sources, but since I know no C, that did little good for me...).
Back to top
View user's profile Send private message
Scandum
Site Admin


Joined: 03 Dec 2004
Posts: 3844

PostPosted: Mon Nov 06, 2006 7:15 pm    Post subject: Reply with quote

My mistake.

s = space_out(s);

is missing in get_arg_stop_spaces in parse.c


Don't think it affects a lot of people, so I'll leave it be till I got some more work done on the next update.

Thanks for letting me know.
Back to top
View user's profile Send private message Send e-mail
mleo2003



Joined: 01 Nov 2006
Posts: 21
Location: Mississippi

PostPosted: Tue Nov 07, 2006 10:14 am    Post subject: Reply with quote

Thanks, I wanted to try out the new version of the client, but couldn't with that not working quite right.

Also, I'm interested to know why no one else seemed to have that problem with their scripts. Am I the only one who puts spaces inbetween consecutive commands?

As always, an excellent product. I love using it.
Back to top
View user's profile Send private message
Scandum
Site Admin


Joined: 03 Dec 2004
Posts: 3844

PostPosted: Tue Nov 07, 2006 6:39 pm    Post subject: Reply with quote

Thanks,

I assume quite a few people just use newlines in script files:
Code:

#alias {bla}
{
       say bli;
       say blo
}

and I've rarely seen anyone putting spaces after the ;
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    The TinTin++ message board Forum Index -> Bug Reports All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Get TinTin++ Mud Client at SourceForge.net. Fast, secure and Free Open Source software downloads Get TinTin++ Mud Client at SourceForge.net. Fast, secure and Free Open Source software downloads
TinTin++ Homepage

Powered by phpBB © 2001, 2002 phpBB Group