TinTin++ Mud Client The TinTin++ message board

 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
TinTin++ Mud Client

A little problem

 
Post new topic   Reply to topic    The TinTin++ message board Forum Index -> General Discussion
View previous topic :: View next topic  
Author Message
Pfhysche



Joined: 11 Feb 2007
Posts: 2

PostPosted: Sun Feb 11, 2007 10:39 am    Post subject: A little problem Reply with quote

Okay, i know this is (or at least part of it) is up here somewhere, as I found it previously, but unforunetly I can't find it anymore Sad

I just want to know what to type to put in his/her things, i thought it was

[his|her]

but that doesn't seem to work, the actions/aliases go in, but they dont set off, where as just leaving it with the appropriate one for the test does. Also, how do i put in a blank?

Ie i want to caputre the mobs name, 'a fish' 'an elephant' 'george', but without the 'a/an' part in it sends that as the command, which obviously isn't a keyword.


One last thing, what are all the different % options, eg %s -string, %w word. There is one for numbers right? I dont beleive %n worked when I last tried it. Also %0, %1, %2 etc, that would be a string command ?


Thanks anyone and everyone who replies Smile
Pfhysche
Back to top
View user's profile Send private message
Scandum
Site Admin


Joined: 03 Dec 2004
Posts: 3770

PostPosted: Sun Feb 11, 2007 12:08 pm    Post subject: Re: A little problem Reply with quote

Pfhysche wrote:

I just want to know what to type to put in his/her things, i thought it was

[his|her]

but that doesn't seem to work, the actions/aliases go in, but they dont set off, where as just leaving it with the appropriate one for the test does.

Odd, it works for me. Make sure you get the spaces right.

Quote:
Also, how do i put in a blank?

[his|her|] should do the trick.

Quote:
Ie i want to caputre the mobs name, 'a fish' 'an elephant' 'george', but without the 'a/an' part in it sends that as the command, which obviously isn't a keyword.

#act {You see [a |an |]%1 standing here.} {say hi %1}

Quote:

One last thing, what are all the different % options, eg %s -string, %w word. There is one for numbers right? I dont beleive %n worked when I last tried it. Also %0, %1, %2 etc, that would be a string command ?

Tintin doesn't have %s %w and %d, just %0 to %9. I might add them sometime in the future.
Back to top
View user's profile Send private message Send e-mail
Pfhysche



Joined: 11 Feb 2007
Posts: 2

PostPosted: Mon Feb 12, 2007 9:03 am    Post subject: Reply with quote

Thanks man, helps heaps. I dont know why the [] didn't work, but I fiugred out why the a//an didn't, it was the space.

I put in [a|an|] %1, rather than having the space IN the brackets, that seems to have solved the problem. Smile
Back to top
View user's profile Send private message
Scandum
Site Admin


Joined: 03 Dec 2004
Posts: 3770

PostPosted: Mon Feb 12, 2007 10:22 am    Post subject: Reply with quote

<pre>" [a|an|] %1" leaves " %1" if there is no match.
" [a |an |]%1" leaves " %1" if there is no match.</pre>
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    The TinTin++ message board Forum Index -> General Discussion All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Get TinTin++ Mud Client at SourceForge.net. Fast, secure and Free Open Source software downloads Get TinTin++ Mud Client at SourceForge.net. Fast, secure and Free Open Source software downloads
TinTin++ Homepage

Powered by phpBB © 2001, 2002 phpBB Group