TinTin++ Mud Client The TinTin++ message board

 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
TinTin++ Mud Client

Cygwin package

 
Post new topic   Reply to topic    The TinTin++ message board Forum Index -> General Discussion
View previous topic :: View next topic  
Author Message
dawang10



Joined: 14 Feb 2015
Posts: 66

PostPosted: Wed Feb 15, 2017 4:48 am    Post subject: Cygwin package Reply with quote

I am returning to tintin++ for tmux..

But Cygwin packages have been updated a lot compared to the one I installed 2 years ago. There were lots of No shown in configuring.
And the same scripts which I used in Tintin++ before and worked doesn't work now.

Did I install all the correct packages?
Devel: select gcc--core, make.
Editors: Joe
Text: select pcre.
Libs: select libpcre-devel, zlib-devel, I didn't find gnutls-devel
Net: select inetutils.
System: select util-linux, didn't find this..
Back to top
View user's profile Send private message
dawang10



Joined: 14 Feb 2015
Posts: 66

PostPosted: Wed Feb 15, 2017 7:56 am    Post subject: Reply with quote

Did I miss something?

checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.exe
checking for suffix of executables... .exe
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking whether make sets $(MAKE)... yes
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking arpa/inet.h usability... yes
checking arpa/inet.h presence... yes
checking for arpa/inet.h... yes
checking ctype.h usability... yes
checking ctype.h presence... yes
checking for ctype.h... yes
checking fcntl.h usability... yes
checking fcntl.h presence... yes
checking for fcntl.h... yes
checking net/errno.h usability... no
checking net/errno.h presence... no
checking for net/errno.h... no
checking netdb.h usability... yes
checking netdb.h presence... yes
checking for netdb.h... yes
checking netinet/in.h usability... yes
checking netinet/in.h presence... yes
checking for netinet/in.h... yes
checking param.h usability... no
checking param.h presence... no
checking for param.h... no
checking pthread.h usability... yes
checking pthread.h presence... yes
checking for pthread.h... yes
checking socks.h usability... no
checking socks.h presence... no
checking for socks.h... no
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for strings.h... (cached) yes
checking sys/ioctl.h usability... yes
checking sys/ioctl.h presence... yes
checking for sys/ioctl.h... yes
checking sys/param.h usability... yes
checking sys/param.h presence... yes
checking for sys/param.h... yes
checking sys/ptem.h usability... no
checking sys/ptem.h presence... no
checking for sys/ptem.h... no
checking sys/socket.h usability... yes
checking sys/socket.h presence... yes
checking for sys/socket.h... yes
checking sys/termio.h usability... yes
checking sys/termio.h presence... yes
checking for sys/termio.h... yes
checking sys/time.h usability... yes
checking sys/time.h presence... yes
checking for sys/time.h... yes
checking time.h usability... yes
checking time.h presence... yes
checking for time.h... yes
checking for unistd.h... (cached) yes
checking util.h usability... no
checking util.h presence... no
checking for util.h... no
checking pty.h usability... yes
checking pty.h presence... yes
checking for pty.h... yes
checking stropts.h usability... no
checking stropts.h presence... no
checking for stropts.h... no
checking zlib.h usability... yes
checking zlib.h presence... yes
checking for zlib.h... yes
checking pcre.h usability... yes
checking pcre.h presence... yes
checking for pcre.h... yes
checking gnutls/gnutls.h usability... yes
checking gnutls/gnutls.h presence... yes
checking for gnutls/gnutls.h... yes
checking for an ANSI C-conforming const... yes
checking for stdbool.h that conforms to C99... yes
checking for _Bool... yes
checking for size_t... yes
checking whether time.h and sys/time.h may both be included... yes
checking whether struct tm is in sys/time.h or time.h... time.h
checking for working memcmp... yes
checking for stdlib.h... (cached) yes
checking for GNU libc compatible realloc... yes
checking sys/select.h usability... yes
checking sys/select.h presence... yes
checking for sys/select.h... yes
checking for sys/socket.h... (cached) yes
checking types of arguments for select... int,fd_set *,struct timeval *
checking return type of signal handlers... void
checking whether lstat correctly handles trailing slash... yes
checking whether stat accepts an empty string... no
checking for strftime... yes
checking for utime.h... yes
checking whether utime accepts a null argument... yes
checking for vprintf... yes
checking for _doprnt... no
checking for gethostbyname... yes
checking for gethostname... yes
checking for gettimeofday... yes
checking for inet_ntoa... yes
checking for memset... yes
checking for select... yes
checking for socket... yes
checking for strcasecmp... yes
checking for strchr... yes
checking for strdup... yes
checking for strerror... yes
checking for strftime... (cached) yes
checking for strncasecmp... yes
checking for strstr... yes
checking for utime... yes
checking for getaddrinfo... yes
checking for forkpty... yes
checking for popen... yes
checking for inflate in -lz... yes
checking for pthread_create in -lpthread... yes
checking for gethostbyname in -lnsl... no
checking for rresvport in -lsocket... no
checking for forkpty in -lutil... yes
checking for pcre_compile in -lpcre... yes
checking for gnutls_init in -lgnutls... yes
checking for sqrt in -lm... yes
checking for gmake... no
checking for make... make
checking for /dev/ptmx... yes
checking for library containing getmntent... none required
checking for dirent.h that defines DIR... yes
checking for library containing opendir... none required

error is shown here

DEBUG_STACK[010] = script_driver(0x6000e1af0,1,0x60011cf90)
DEBUG_STACK[011] = do_read(0x6000e1af0,0x600125a60)
DEBUG_STACK[012] = script_driver(0x6000e1af0,3,0x60015bee0)
DEBUG_STACK[013] = do_action(0x6000e1af0,0x6001761b0)
Back to top
View user's profile Send private message
PowerGod



Joined: 04 Aug 2014
Posts: 339

PostPosted: Wed Feb 15, 2017 2:31 pm    Post subject: Reply with quote

You can do a diff with the ones I have installed, my list is generated by
Code:

cygcheck -c > list.txt


Code:

Cygwin Package Information
Package                                 Version                        Status
_autorebase                             001004-1                       OK
_update-info-dir                        03000-1                        OK
alternatives                            1.3.30c-10                     OK
autoconf                                13-1                           OK
autoconf2.1                             2.13-12                        OK
autoconf2.5                             2.69-3                         OK
automake                                9-1                            OK
automake1.10                            1.10.3-2                       OK
automake1.11                            1.11.6-2                       OK
automake1.12                            1.12.6-2                       OK
automake1.13                            1.13.4-1                       OK
automake1.14                            1.14.1-2                       OK
automake1.15                            1.15-1                         OK
automake1.4                             1.4p6-11                       OK
automake1.5                             1.5-11                         OK
automake1.6                             1.6.3-12                       OK
automake1.7                             1.7.9-11                       OK
automake1.8                             1.8.5-11                       OK
automake1.9                             1.9.6-11                       OK
base-cygwin                             3.8-1                          OK
base-files                              4.2-4                          OK
bash                                    4.4.12-3                       OK
binutils                                2.25-4                         OK
boost-debuginfo                         1.60.0-2                       OK
bzip2                                   1.0.6-2                        OK
ca-certificates                         2.11-1                         OK
cmake                                   3.6.2-1                        OK
cmake-debuginfo                         3.6.2-1                        OK
coreutils                               8.26-1                         OK
crypt                                   1.4-1                          OK
csih                                    0.9.9-1                        OK
cygrunsrv                               1.62-1                         OK
cygutils                                1.4.15-2                       OK
cygwin                                  2.7.0-1                        OK
cygwin-debuginfo                        2.7.0-1                        OK
cygwin-devel                            2.7.0-1                        OK
cygwin32                                2.6.0-1                        OK
cygwin32-binutils                       2.25-1                         OK
cygwin32-default-manifest               6.4-1                          OK
cygwin32-gcc-core                       5.4.0-1                        OK
cygwin32-gcc-g++                        5.4.0-1                        OK
cygwin32-gcc-objc                       5.4.0-1                        OK
cygwin32-gcc-objc++                     5.4.0-1                        OK
cygwin32-gettext                        0.19.5.1-1                     OK
cygwin32-gmp                            5.1.1-1                        OK
cygwin32-gnutls                         3.2.0-1                        OK
cygwin32-libffi                         3.0.13-1                       OK
cygwin32-libiconv                       1.14-2                         OK
cygwin32-libtasn1                       3.3-1                          OK
cygwin32-nettle                         2.7-1                          OK
cygwin32-p11-kit                        0.19.1-1                       OK
cygwin32-pcre                           8.32-1                         OK
cygwin32-w32api-headers                 4.0.4-1                        OK
cygwin32-w32api-runtime                 4.0.4-1                        OK
cygwin32-zlib                           1.2.8-1                        OK
dash                                    0.5.8-3                        OK
desktop-file-utils                      0.23-1                         OK
diffutils                               3.5-2                          OK
editrights                              1.03-1                         OK
fdupes                                  1.50-PR2-3                     OK
file                                    5.25-1                         OK
findutils                               4.6.0-1                        OK
gamin                                   0.1.10-15                      OK
gawk                                    4.1.4-2                        OK
gcc-core                                5.4.0-1                        OK
gcc-g++                                 5.4.0-1                        OK
gcc-objc                                5.4.0-1                        OK
gcc-objc++                              5.4.0-1                        OK
gcc-tools-epoch1-autoconf               2.59-2                         OK
gcc-tools-epoch1-automake               1.9.6-2                        OK
gcc-tools-epoch2-autoconf               2.64-2                         OK
gcc-tools-epoch2-automake               1.11.6-1                       OK
gccmakedep                              1.0.3-1                        OK
gdb                                     7.10.1-1                       OK
gdb-debuginfo                           7.10.1-1                       OK
getent                                  2.18.90-4                      OK
girepository-GLib2.0                    1.46.0-1                       OK
girepository-Json1.0                    1.0.4-1                        OK
git                                     2.8.3-1                        OK
gmp                                     6.1.2-1                        OK
gnutls                                  3.3.17-1                       OK
grep                                    3.0-1                          OK
groff                                   1.22.3-1                       OK
gsettings-desktop-schemas               3.18.1-1                       OK
gzip                                    1.8-1                          OK
help2man                                1.47.4-1                       OK
hostname                                3.13-1                         OK
inetutils                               1.9.1-2                        OK
inetutils-server                        1.9.1-2                        OK
info                                    6.3-1                          OK
ipc-utils                               1.0-2                          OK
iperf                                   2.0.5-1                        OK
json-c-debuginfo                        0.12-1                         OK
json-glib1.0                            1.0.4-1                        OK
json-glib1.0-debuginfo                  1.0.4-1                        OK
less                                    481-1                          OK
libarchive13                            3.2.2-1                        OK
libargp                                 20110921-3                     OK
libatomic1                              5.4.0-1                        OK
libattr1                                2.4.46-1                       OK
libblkid1                               2.25.2-2                       OK
libboost-devel                          1.60.0-2                       OK
libboost_atomic1.60                     1.60.0-2                       OK
libboost_chrono1.60                     1.60.0-2                       OK
libboost_container1.60                  1.60.0-2                       OK
libboost_context1.60                    1.60.0-2                       OK
libboost_coroutine1.60                  1.60.0-2                       OK
libboost_date_time1.60                  1.60.0-2                       OK
libboost_filesystem1.60                 1.60.0-2                       OK
libboost_graph1.60                      1.60.0-2                       OK
libboost_iostreams1.60                  1.60.0-2                       OK
libboost_locale1.60                     1.60.0-2                       OK
libboost_log1.60                        1.60.0-2                       OK
libboost_math1.60                       1.60.0-2                       OK
libboost_program_options1.60            1.60.0-2                       OK
libboost_random1.60                     1.60.0-2                       OK
libboost_regex1.60                      1.60.0-2                       OK
libboost_serialization1.60              1.60.0-2                       OK
libboost_signals1.60                    1.60.0-2                       OK
libboost_system1.60                     1.60.0-2                       OK
libboost_test1.60                       1.60.0-2                       OK
libboost_thread1.60                     1.60.0-2                       OK
libboost_timer1.60                      1.60.0-2                       OK
libboost_type_erasure1.60               1.60.0-2                       OK
libboost_wave1.60                       1.60.0-2                       OK
libbz2_1                                1.0.6-2                        OK
libcatgets1                             1.1-2                          OK
libcharset1                             1.14-3                         OK
libcloog-isl4                           0.18.0-2                       OK
libcom_err2                             1.42.12-2                      OK
libcrypt0                               1.4-1                          OK
libcurl-devel                           7.52.1-1                       OK
libcurl4                                7.52.1-1                       OK
libdb5.3                                5.3.28-1                       OK
libedit0                                20130712-1                     OK
libevent2.0_5                           2.0.22-1                       OK
libexpat1                               2.2.0-0                        OK
libext2fs2                              1.42.12-2                      OK
libfam0                                 0.1.10-15                      OK
libffi6                                 3.2.1-2                        OK
libgcc1                                 5.4.0-1                        OK
libgdbm4                                1.12-1                         OK
libglib2.0-devel                        2.46.2-4                       OK
libglib2.0_0                            2.46.2-4                       OK
libgmp-devel                            6.1.2-1                        OK
libgmp10                                6.1.2-1                        OK
libgmpxx4                               6.1.2-1                        OK
libgnutls-devel                         3.3.17-1                       OK
libgnutls28                             3.3.17-1                       OK
libgomp1                                5.4.0-1                        OK
libgssapi_krb5_2                        1.14.4-1                       OK
libguile17                              1.8.8-1                        OK
libhogweed2                             2.7.1-1                        OK
libiconv                                1.14-3                         OK
libiconv-devel                          1.14-3                         OK
libiconv2                               1.14-3                         OK
libicu-devel                            58.2-1                         OK
libicu57                                57.1-1                         OK
libicu58                                58.2-1                         OK
libidn11                                1.29-1                         OK
libidn2_0                               0.11-1                         OK
libintl-devel                           0.19.8.1-2                     OK
libintl8                                0.19.8.1-2                     OK
libisl10                                0.11.1-2                       OK
libisl13                                0.14.1-1                       OK
libjson-c-common                        0.12-1                         OK
libjson-c-devel                         0.12-1                         OK
libjson-c2                              0.12-1                         OK
libjson-glib1.0-devel                   1.0.4-1                        OK
libjson-glib1.0_0                       1.0.4-1                        OK
libk5crypto3                            1.14.4-1                       OK
libkrb5_3                               1.14.4-1                       OK
libkrb5support0                         1.14.4-1                       OK
libltdl7                                2.4.6-4                        OK
liblz4_1                                131-1                          OK
liblzma5                                5.2.2-1                        OK
liblzo2_2                               2.08-1                         OK
libmhash2                               0.9.9.9-2                      OK
libmpc3                                 1.0.3-1                        OK
libmpfr4                                3.1.5-1                        OK
libncursesw10                           6.0-9.20170121                 OK
libnettle-devel                         2.7.1-1                        OK
libnettle4                              2.7.1-1                        OK
libnghttp2_14                           1.14.0-1                       OK
liboauth-common                         1.0.3-1                        OK
liboauth-devel                          1.0.3-1                        OK
liboauth0                               1.0.3-1                        OK
libobjc4                                5.4.0-1                        OK
libopenldap2_4_2                        2.4.42-1                       OK
libopenssl100                           1.0.2k-1                       OK
libopts25                               5.18.4-1                       OK
libp11-kit-devel                        0.22.1-1                       OK
libp11-kit0                             0.22.1-1                       OK
libpcre-devel                           8.40-1                         OK
libpcre1                                8.40-1                         OK
libpcre16_0                             8.40-1                         OK
libpcre32_0                             8.40-1                         OK
libpcrecpp0                             8.40-1                         OK
libpcreposix0                           8.40-1                         OK
libpipeline1                            1.4.0-1                        OK
libpopt-common                          1.16-2                         OK
libpopt0                                1.16-2                         OK
libprocps-ng4                           3.3.10-1                       OK
libprocps-ng5                           3.3.11-1                       OK
libpsl5                                 0.17.0-1                       OK
libquadmath0                            5.4.0-1                        OK
libreadline7                            7.0.1-1                        OK
libsasl2_3                              2.1.26-9                       OK
libsigsegv2                             2.10-2                         OK
libslang2                               2.3.1a-1                       OK
libsmartcols1                           2.25.2-2                       OK
libsqlite3_0                            3.16.2-1                       OK
libssh2_1                               1.7.0-1                        OK
libssp0                                 5.4.0-1                        OK
libstdc++6                              5.4.0-1                        OK
libtasn1-devel                          4.9-1                          OK
libtasn1_6                              4.9-1                          OK
libtinyxml2-devel                       4.0.1-1                        OK
libtinyxml2_4                           4.0.1-1                        OK
libtool                                 2.4.6-4                        OK
libunistring2                           0.9.6-1                        OK
libuuid-devel                           2.25.2-2                       OK
libuuid1                                2.25.2-2                       OK
libvtv0                                 5.4.0-1                        OK
libwrap0                                7.6-22                         OK
libxml2                                 2.9.4-1                        OK
login                                   1.11-1                         OK
lynx                                    2.8.7-2                        OK
m4                                      1.4.18-1                       OK
make                                    4.2.1-1                        OK
makedepend                              1.0.5-1                        OK
man-db                                  2.7.5-2                        OK
mc                                      4.8.18-1                       OK
mingw-binutils                          2.23.1-1                       OK
mingw-gcc-core                          4.7.3-1                        OK
mingw-gcc-g++                           4.7.3-1                        OK
mingw-gcc-objc                          4.7.3-1                        OK
mingw-pthreads                          20110507-2                     OK
mingw-runtime                           4.0-1                          OK
mingw-w32api                            4.0-1                          OK
mingw-zlib                              1.2.8-1                        OK
mingw-zlib-devel                        1.2.8-1                        OK
mingw-zlib1                             1.2.8-1                        OK
mingw64-i686-binutils                   2.25.0.1.23f238d-1             OK
mingw64-i686-boost                      1.60.0-2                       OK
mingw64-i686-bzip2                      1.0.6-4                        OK
mingw64-i686-curl                       7.52.1-1                       OK
mingw64-i686-gcc-core                   5.4.0-3                        OK
mingw64-i686-gcc-g++                    5.4.0-3                        OK
mingw64-i686-gettext                    0.19.8.1-2                     OK
mingw64-i686-glib2.0                    2.46.2-1                       OK
mingw64-i686-headers                    5.0.1-1                        OK
mingw64-i686-icu                        57.1-2                         OK
mingw64-i686-json-c                     0.11-2                         OK
mingw64-i686-json-glib1.0               1.0.4-1                        OK
mingw64-i686-libffi                     3.2.1-1                        OK
mingw64-i686-liboauth                   1.0.3-1                        OK
mingw64-i686-libssh2                    1.7.0-2                        OK
mingw64-i686-nghttp2                    1.14.0-1                       OK
mingw64-i686-openssl                    1.0.2k-1                       OK
mingw64-i686-pkg-config                 0.29.1-1                       OK
mingw64-i686-runtime                    5.0.1-1                        OK
mingw64-i686-win-iconv                  0.0.6-2                        OK
mingw64-i686-windows-default-manifest   6.4-1                          OK
mingw64-i686-winpthreads                5.0.1-1                        OK
mingw64-i686-zlib                       1.2.8-4                        OK
mingw64-x86_64-binutils                 2.25.0.1.23f238d-1             OK
mingw64-x86_64-boost                    1.60.0-2                       OK
mingw64-x86_64-bzip2                    1.0.6-4                        OK
mingw64-x86_64-curl                     7.52.1-1                       OK
mingw64-x86_64-gcc-core                 5.4.0-3                        OK
mingw64-x86_64-gcc-g++                  5.4.0-3                        OK
mingw64-x86_64-gcc-objc                 5.4.0-3                        OK
mingw64-x86_64-gettext                  0.19.8.1-2                     OK
mingw64-x86_64-glib2.0                  2.46.2-1                       OK
mingw64-x86_64-gmp                      6.1.2-1                        OK
mingw64-x86_64-gnutls                   3.3.24-2                       OK
mingw64-x86_64-headers                  5.0.1-1                        OK
mingw64-x86_64-icu                      57.1-2                         OK
mingw64-x86_64-json-c                   0.11-2                         OK
mingw64-x86_64-json-glib1.0             1.0.4-1                        OK
mingw64-x86_64-libffi                   3.2.1-2                        OK
mingw64-x86_64-liboauth                 1.0.3-1                        OK
mingw64-x86_64-libssh2                  1.7.0-2                        OK
mingw64-x86_64-libtasn1                 4.9-1                          OK
mingw64-x86_64-nettle                   2.7.1-2                        OK
mingw64-x86_64-nghttp2                  1.14.0-1                       OK
mingw64-x86_64-openssl                  1.0.2k-1                       OK
mingw64-x86_64-p11-kit                  0.22.1-1                       OK
mingw64-x86_64-pkg-config               0.29.1-1                       OK
mingw64-x86_64-runtime                  5.0.1-1                        OK
mingw64-x86_64-win-iconv                0.0.6-2                        OK
mingw64-x86_64-windows-default-manifest 6.4-1                          OK
mingw64-x86_64-winpthreads              5.0.1-1                        OK
mingw64-x86_64-zlib                     1.2.8-4                        OK
mintty                                  2.7.4-0                        OK
ncurses                                 6.0-9.20170121                 OK
openssh                                 7.4p1-1                        OK
openssl                                 1.0.2k-1                       OK
openssl-devel                           1.0.2k-1                       OK
p11-kit                                 0.22.1-1                       OK
p11-kit-trust                           0.22.1-1                       OK
p7zip                                   15.14.1-1                      OK
pcre                                    8.40-1                         OK
pcre-debuginfo                          8.40-1                         OK
perl                                    5.22.3-1                       OK
perl-Carp                               1.38-1                         OK
perl-Error                              0.17024-1                      OK
perl-gettext                            1.07-1                         OK
perl-Pod-Simple                         3.35-1                         OK
perl-TermReadKey                        2.37-1                         OK
perl-TimeDate                           2.30-2                         OK
perl-Unicode-Normalize                  1.25-1                         OK
perl_autorebase                         5.22.3-1                       OK
perl_base                               5.22.3-1                       OK
pkg-config                              0.29.1-1                       OK
popt                                    1.16-2                         OK
procps-ng                               3.3.11-1                       OK
publicsuffix-list-dafsa                 20170116-1                     OK
python                                  2.7.12-1                       OK
rebase                                  4.4.2-1                        OK
rsync                                   3.1.2-1                        OK
run                                     1.3.4-2                        OK
sed                                     4.2.2-3                        OK
shared-mime-info                        1.7-1                          OK
sqlite3                                 3.16.2-1                       OK
sqlite3-vfslog                          3.16.2-1                       OK
tar                                     1.29-1                         OK
tcsh                                    6.20.00-1                      OK
terminfo                                6.0-9.20170121                 OK
texinfo                                 6.3-1                          OK
tmux                                    2.3-2                          OK
tzcode                                  2016j-1                        OK
tzdata                                  2016j-1                        OK
unzip                                   6.0-15                         OK
util-linux                              2.25.2-2                       OK
vim                                     8.0.0244-1                     OK
vim-common                              8.0.0244-1                     OK
vim-minimal                             8.0.0244-1                     OK
w32api-headers                          4.0.4-1                        OK
w32api-runtime                          4.0.4-1                        OK
wget                                    1.19-1                         OK
which                                   2.20-2                         OK
windows-default-manifest                6.4-1                          OK
xlsx2csv                                0.11+20120814+gitf54ab78-1     OK
xxd                                     8.0.0244-1                     OK
xz                                      5.2.2-1                        OK
zip                                     3.0-12                         OK
zlib                                    1.2.8-3                        OK
zlib-devel                              1.2.8-3                        OK
zlib0                                   1.2.8-3                        OK
Back to top
View user's profile Send private message
dawang10



Joined: 14 Feb 2015
Posts: 66

PostPosted: Wed Feb 15, 2017 4:18 pm    Post subject: Reply with quote

Code:

Cygwin Package Information
Package                                 Version                Status
_autorebase                             001004-1               OK
alternatives                            1.3.30c-10             OK
base-cygwin                             3.8-1                  OK
base-files                              4.2-4                  OK
bash                                    4.4.12-3               OK
binutils                                2.25-4                 OK
bzip2                                   1.0.6-2                OK
ca-certificates                         2.11-1                 OK
coreutils                               8.26-2                 OK
csih                                    0.9.9-1                OK
cygrunsrv                               1.62-1                 OK
cygutils                                1.4.15-2               OK
cygwin                                  2.7.0-1                OK
cygwin-devel                            2.7.0-1                OK
dash                                    0.5.8-3                OK
desktop-file-utils                      0.23-1                 OK
diffutils                               3.5-2                  OK
editrights                              1.03-1                 OK
file                                    5.25-1                 OK
findutils                               4.6.0-1                OK
gamin                                   0.1.10-15              OK
gawk                                    4.1.4-2                OK
gcc-core                                5.4.0-1                OK
getent                                  2.18.90-4              OK
gmp                                     6.1.2-1                OK
grep                                    3.0-1                  OK
groff                                   1.22.3-1               OK
gsettings-desktop-schemas               3.18.1-1               OK
gzip                                    1.8-1                  OK
hostname                                3.13-1                 OK
inetutils                               1.9.1-2                OK
inetutils-server                        1.9.1-2                OK
info                                    6.3-1                  OK
ipc-utils                               1.0-2                  OK
less                                    481-1                  OK
libargp                                 20110921-3             OK
libatomic1                              5.4.0-1                OK
libattr1                                2.4.46-1               OK
libblkid1                               2.25.2-2               OK
libbz2_1                                1.0.6-2                OK
libcharset1                             1.14-3                 OK
libcom_err2                             1.42.12-2              OK
libcrypt0                               1.4-1                  OK
libedit0                                20130712-1             OK
libfam0                                 0.1.10-15              OK
libffi6                                 3.2.1-2                OK
libgcc1                                 5.4.0-1                OK
libgdbm4                                1.12-1                 OK
libglib2.0_0                            2.46.2-4               OK
libgmp-devel                            6.1.2-1                OK
libgmp10                                6.1.2-1                OK
libgmpxx4                               6.1.2-1                OK
libgnutls-devel                         3.3.17-1               OK
libgnutls28                             3.3.17-1               OK
libgomp1                                5.4.0-1                OK
libgssapi_krb5_2                        1.14.4-1               OK
libguile17                              1.8.8-1                OK
libhogweed2                             2.7.1-1                OK
libiconv                                1.14-3                 OK
libiconv-devel                          1.14-3                 OK
libiconv2                               1.14-3                 OK
libintl-devel                           0.19.8.1-2             OK
libintl8                                0.19.8.1-2             OK
libisl13                                0.14.1-1               OK
libk5crypto3                            1.14.4-1               OK
libkrb5_3                               1.14.4-1               OK
libkrb5support0                         1.14.4-1               OK
libltdl7                                2.4.6-4                OK
liblzma5                                5.2.2-1                OK
libmpc3                                 1.0.3-1                OK
libmpfr4                                3.1.5-1                OK
libncursesw10                           6.0-9.20170121         OK
libnettle-devel                         2.7.1-1                OK
libnettle4                              2.7.1-1                OK
libopenssl100                           1.0.2k-1               OK
libp11-kit-devel                        0.22.1-1               OK
libp11-kit0                             0.22.1-1               OK
libpcre-devel                           8.40-1                 OK
libpcre1                                8.40-1                 OK
libpcre16_0                             8.40-1                 OK
libpcre32_0                             8.40-1                 OK
libpcrecpp0                             8.40-1                 OK
libpcreposix0                           8.40-1                 OK
libpipeline1                            1.4.0-1                OK
libpopt-common                          1.16-2                 OK
libpopt0                                1.16-2                 OK
libquadmath0                            5.4.0-1                OK
libreadline7                            7.0.3-3                OK
libsigsegv2                             2.10-2                 OK
libsmartcols1                           2.25.2-2               OK
libssp0                                 5.4.0-1                OK
libstdc++6                              5.4.0-1                OK
libtasn1-devel                          4.9-1                  OK
libtasn1_6                              4.9-1                  OK
libuuid1                                2.25.2-2               OK
libvtv0                                 5.4.0-1                OK
libwrap0                                7.6-22                 OK
libxml2                                 2.9.4-1                OK
login                                   1.11-1                 OK
make                                    4.2.1-1                OK
man-db                                  2.7.5-2                OK
mingw64-x86_64-binutils                 2.25.0.1.23f238d-1     OK
mingw64-x86_64-gcc-core                 5.4.0-3                OK
mingw64-x86_64-headers                  5.0.1-1                OK
mingw64-x86_64-runtime                  5.0.1-1                OK
mingw64-x86_64-windows-default-manifest 6.4-1                  OK
mingw64-x86_64-winpthreads              5.0.1-1                OK
mintty                                  2.7.4-0                OK
ncurses                                 6.0-9.20170121         OK
openssl                                 1.0.2k-1               OK
p11-kit                                 0.22.1-1               OK
p11-kit-trust                           0.22.1-1               OK
pcre                                    8.40-1                 OK
pkg-config                              0.29.1-1               OK
rebase                                  4.4.2-1                OK
run                                     1.3.4-2                OK
sed                                     4.2.2-3                OK
shared-mime-info                        1.7-1                  OK
tar                                     1.29-1                 OK
terminfo                                6.0-9.20170121         OK
tzcode                                  2016j-1                OK
tzdata                                  2016j-1                OK
util-linux                              2.25.2-2               OK
vim-minimal                             8.0.0244-1             OK
w32api-headers                          4.0.4-1                OK
w32api-runtime                          4.0.4-1                OK
which                                   2.20-2                 OK
windows-default-manifest                6.4-1                  OK
xz                                      5.2.2-1                OK
zlib-devel                              1.2.8-3                OK
zlib0                                   1.2.8-3                OK


This is mine.

I guess yours must be 2GB, I don't need that much, just essential packages first.
Back to top
View user's profile Send private message
dawang10



Joined: 14 Feb 2015
Posts: 66

PostPosted: Wed Feb 15, 2017 4:57 pm    Post subject: Reply with quote

got the reason of error

it's due to the version 2.01.2, same scripts also got error in wintin-2.01.2

trying on older versions.
Back to top
View user's profile Send private message
PowerGod



Joined: 04 Aug 2014
Posts: 339

PostPosted: Wed Feb 15, 2017 5:00 pm    Post subject: Reply with quote

I gave the list to make you have a look at what you could be missing, not to install everything... I always lose myself too in this sea of packets, but I use Cygwin for everything, not only for tt++

anyway I see that in the mean time you added more libs and found util-linux
and libgnutls-devel

After a recompile you should find out where exactly your tt++ script gives the error, so if you know what function is involved could be easier to find out if it's caused by a missing lib
Back to top
View user's profile Send private message
dawang10



Joined: 14 Feb 2015
Posts: 66

PostPosted: Thu Feb 16, 2017 4:09 am    Post subject: Reply with quote

Thanks,

I am sure it's the problem of tt version 2.01.2

My script is working well in tt2.01.1

Is there a website for beginners to learn cygwin and tmux?

http://tintin.sourceforge.net/board/viewtopic.php?t=2099&highlight=tmux

I am impressed by those screenshots. it's really cool to customise own mud client
Back to top
View user's profile Send private message
PowerGod



Joined: 04 Aug 2014
Posts: 339

PostPosted: Thu Feb 16, 2017 2:00 pm    Post subject: Reply with quote

I actually always used google to find answers about tmux and cygwin, because it's really a huge argument...

Mainly cygwin works as linux does, so many commands or patterns can be learned from linux guides...

Just read the official cygwin FAQ to learn about the basics, like how the path works ("c:\folder\filename.txt" becomes "/cygdrive/c/folder/filename.txt"), or how them can be converted with "cygpath"... so you can launch without too much issues windows programs as well (cygwin covers the entire system, so you can almost use your entire windows os from there).

About tmux it's a little mess at the beginning, you'll have A LOT of hotkeys to memorize (and also print !! PREPARE YOURSELFE !!)

I can give a little example to start tmux with 2 terminals in the same window:
Code:

tmux
[CTRL+b]  (this will enter the "command mode of tmux", every other keys after this are the actual action to do)
%  (this will split vertically opening another terminal at the side)
to go from one terminal to the other just do
[CTRL+b] [right arrow] or [left arrow]


then in one of them just run tt++ with something that uses a "#map map" command to constantly save the map in a file (mymap.map)
and in the other terminal use a command like this
Code:

tail -fs1 mymap.map

that will monitor the file and it will read it again at every modification

("[CTRL+b] ?" will give you all the tmux hotkeys)
Back to top
View user's profile Send private message
dawang10



Joined: 14 Feb 2015
Posts: 66

PostPosted: Thu Feb 16, 2017 2:44 pm    Post subject: Reply with quote

Thank you very much.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    The TinTin++ message board Forum Index -> General Discussion All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Get TinTin++ Mud Client at SourceForge.net. Fast, secure and Free Open Source software downloads Get TinTin++ Mud Client at SourceForge.net. Fast, secure and Free Open Source software downloads
TinTin++ Homepage

Powered by phpBB © 2001, 2002 phpBB Group