TinTin++ Mud Client The TinTin++ message board

 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
TinTin++ Mud Client

bug with #alias and many long #showmes

 
Post new topic   Reply to topic    The TinTin++ message board Forum Index -> Bug Reports
View previous topic :: View next topic  
Author Message
magiko



Joined: 11 May 2006
Posts: 33

PostPosted: Thu May 11, 2006 11:39 pm    Post subject: bug with #alias and many long #showmes Reply with quote

The example i'm going to use is absurd, but it's super easy to recrete the problem with. I really do have a legit reason that blows up in an identical fashion. I cannot tonight speak to causes, only symptoms.

a pattern works best to see the symptom, and a good pattern is the alphabet.

How to recreate:

Create an alias (mine was called 'neon'), that does:
#alias {neon}
{
#showme <alphabet><alphabet><alphabet>;
a total of 16 times
(where <alphabet> is all 26 characters - so 3x16 alphabets).
}

On my version (1.95.6, Mac OS X precompiled binary)
It skips characters. What's more interesting is that if i redo the alias, the skipped characters either move, or I see something like

#ERROR: #UNKNOWN TINTIN-COMMAND 'shome'.

because the character that it skipped happened to be in the showme command.

The legit use is less data than this, but I really wanted to present the problem. I code, but didn't really want to wade into the source very far if someone else was going to see the problem from 20,000 ft.
Back to top
View user's profile Send private message
magiko



Joined: 11 May 2006
Posts: 33

PostPosted: Thu May 11, 2006 11:51 pm    Post subject: Reply with quote

I now think this is a problem with pasting into Apple's terminal app. I can paste my alias just fine into anything else, but terminal skips chars on large pastes.

If I find out more I'll let you know. Sorry for the false alarm, i'll edit my #write file directly for my current use.

j
Back to top
View user's profile Send private message
Scandum
Site Admin


Joined: 03 Dec 2004
Posts: 3796

PostPosted: Fri May 12, 2006 12:41 pm    Post subject: Reply with quote

=]
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    The TinTin++ message board Forum Index -> Bug Reports All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Get TinTin++ Mud Client at SourceForge.net. Fast, secure and Free Open Source software downloads Get TinTin++ Mud Client at SourceForge.net. Fast, secure and Free Open Source software downloads
TinTin++ Homepage

Powered by phpBB © 2001, 2002 phpBB Group