TinTin++ Mud Client The TinTin++ message board

 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
TinTin++ Mud Client

#showme in macros with #split

 
Post new topic   Reply to topic    The TinTin++ message board Forum Index -> Bug Reports
View previous topic :: View next topic  
Author Message
davevnj



Joined: 22 Nov 2006
Posts: 55

PostPosted: Sun Dec 24, 2006 5:15 pm    Post subject: #showme in macros with #split Reply with quote

If you do a #showme command in a macro (with split active), the last line of text output (generally the prompt) is overwritten.

Here's an example to illustrate:

#macro {keycode} {#showme {MACROS RULE!}}

If you prompt was: Just some dumb prompt>, after hitting the macro key, the last line would read:

MACROS RULE!mb prompt>

(and the buffer advances a line) Also note that the prompt does not have a linefeed character terminating the line.

I've noticed a couple other wierd buffer position type things that are affecting my actions, but I'll try to get a more solid test case together. Basically it looks like after handling the prompt, when the mud sends the next line, it has the newline character on the next line, but tintin may be eating this somehow, which means the new text appears on the same line as the prompt and actions which trigger on the beginning of the line (#action {^some test} {some action}) aren't getting hit. But I may have other weird things going on too... more on this whenever I get to it.
Back to top
View user's profile Send private message Visit poster's website
Scandum
Site Admin


Joined: 03 Dec 2004
Posts: 3796

PostPosted: Tue Dec 26, 2006 1:11 pm    Post subject: Reply with quote

Using #prompt or adding a carriage return to your prompt should fix this. I can't really look into it right now, but I'll see if I can fix it sometime.
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    The TinTin++ message board Forum Index -> Bug Reports All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Get TinTin++ Mud Client at SourceForge.net. Fast, secure and Free Open Source software downloads Get TinTin++ Mud Client at SourceForge.net. Fast, secure and Free Open Source software downloads
TinTin++ Homepage

Powered by phpBB © 2001, 2002 phpBB Group