TinTin++ Mud Client The TinTin++ message board

 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
TinTin++ Mud Client

Not sure what's going on here..

 
Post new topic   Reply to topic    The TinTin++ message board Forum Index -> Bug Reports
View previous topic :: View next topic  
Author Message
abedour



Joined: 29 Oct 2010
Posts: 37

PostPosted: Mon Jan 04, 2016 7:08 pm    Post subject: Not sure what's going on here.. Reply with quote

Just moved my scripts over to my mac, from my linux computer. I didn't think scripts had any differences between the two systems, but I guess I'm way wrong.

Can anyone debug this and tell me where it's hanging up?

Code:
DEBUG_STACK[000] = poll_sessions(void)
DEBUG_STACK[001] = readmud(0x7fd1a4039e00)
DEBUG_STACK[002] = process_mud_output(0x7fd1a4039e00,0x7fff5196c7e0,0)
DEBUG_STACK[003] = [ForsakenLands] do_one_line(Aksur: [100])
DEBUG_STACK[004] = substitute(0x7fd1a4039e00,0x7fd1a3c15080,0x7fff519446c0,31)
DEBUG_STACK[005] = script_driver(0x7fd1a4039e00,7,0x7fff5192c610)
DEBUG_STACK[006] = substitute(0x7fd1a4039e00,0x7fd1a3e0a740,0x7fff5191c1b0,6)
DEBUG_STACK[007] = script_driver(0x7fd1a4039e00,7,0x7fff5190c160)
DEBUG_STACK[008] = do_format(0x7fd1a4039e00,0x7fd1a3e0ac80)
Back to top
View user's profile Send private message
abedour



Joined: 29 Oct 2010
Posts: 37

PostPosted: Mon Jan 04, 2016 7:27 pm    Post subject: Reply with quote

Apparently the following was the issue:

Code:
{5}
#FUNCTION {tank1}
{
        #var c %1;
        #replace {c} {:} {};
        #format {res} {%p} {$c};
        #return $res
}
{5}
#FUNCTION {tankbar}
{
        #if {!%1} {#return 0};
        #else {
                #var b %1;
                #replace {b} {[} {};
                #replace {b} {]} {};
                #format {res2} {%p} {$b};
                #return $res2
        }
}


Which replaced the following line:

Aksur: [100]

to make it look like:

Aksur 100

(or remove the ['s and ]'s and Smile.

When removed, it already removed them for me, for some odd reason, with the following function:

Code:
#function {tank_prompt}
{
                #return <G00> <ddd>%1<g22> @ <ddd>%2<bbb>% <088>
}


Funnily enough, I code for the MUD and I know the output should now show:

Aksur: @ [100]%

but it returns it like normal:

Aksur @ 100%

..


Weird.
Back to top
View user's profile Send private message
Scandum
Site Admin


Joined: 03 Dec 2004
Posts: 3770

PostPosted: Wed Aug 24, 2016 9:35 pm    Post subject: Reply with quote

Seems like there's a problem with #format %p on OS X.

Will look into it if I find the time.
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    The TinTin++ message board Forum Index -> Bug Reports All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Get TinTin++ Mud Client at SourceForge.net. Fast, secure and Free Open Source software downloads Get TinTin++ Mud Client at SourceForge.net. Fast, secure and Free Open Source software downloads
TinTin++ Homepage

Powered by phpBB © 2001, 2002 phpBB Group