TinTin++ Mud Client The TinTin++ message board

 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
TinTin++ Mud Client

#split creates text format issues

 
Post new topic   Reply to topic    The TinTin++ message board Forum Index -> Script Help
View previous topic :: View next topic  
Author Message
vision



Joined: 01 Feb 2014
Posts: 32

PostPosted: Tue Jun 28, 2016 11:30 pm    Post subject: #split creates text format issues Reply with quote

I use #split 0 6 (and then #show {info I want to show on this line} +2, etc. for tracking my prompts, things like HP, SP, what spells are active etc. Works great but whenever I use #split some lines just disappear, I tried Packet Patch and that has not worked. It is very consistent that it happens when I leverage #split. I have tried MacOS, and Debian, and multiple terms and emulations.

Please let me know if anyone has found fix besides packet patch (as that is not working), I tried NC to another window but I could not figure a great solution for not having the variables scroll up the screen. No way to #send to the NC session and specify the split line.

Thanks,
Stan
Back to top
View user's profile Send private message
PowerGod



Joined: 04 Aug 2014
Posts: 339

PostPosted: Wed Jun 29, 2016 2:02 pm    Post subject: Reply with quote

What do you mean by this ?
Quote:

whenever I use #split some lines just disappear


Do you use #split command more than once ?
Back to top
View user's profile Send private message
vision



Joined: 01 Feb 2014
Posts: 32

PostPosted: Thu Jun 30, 2016 9:49 pm    Post subject: #split Reply with quote

When I logon to the mud (this is multiple muds), no issues with text being sent from the mud being truncated, coming across incorrectly, or full lines of text disappearing. When I enable split I start to have issues. This is just a clean session no gags, actions, or subs running. This is #split of one line or 6 (which is what I typically use). It is clearly an issue with split and packet patch does not appear to work to correct it completely although it does tend to help the truncation and formatting, I still have issues with full lines of text not being displayed. Not sure if anyone has had the same issues and worked through a solution, or if anyone has another solution besides split for displaying variables. Such as NC to another window.
Back to top
View user's profile Send private message
PowerGod



Joined: 04 Aug 2014
Posts: 339

PostPosted: Tue Jul 05, 2016 4:47 am    Post subject: Reply with quote

You should try recording a RAW log while playing, so you can see what lines are coming when issues happens.

Also, how many values have you tried with packet patch ?
Back to top
View user's profile Send private message
vision



Joined: 01 Feb 2014
Posts: 32

PostPosted: Tue Jul 05, 2016 11:21 am    Post subject: Packet Patch Reply with quote

I will try logging and see if I can work through some pattern and if the text comes across in the log. I have tried packet patch .50 .25 .30. Let me know if there are some other options I should try. I will report back on the log.
Back to top
View user's profile Send private message
vision



Joined: 01 Feb 2014
Posts: 32

PostPosted: Tue Jul 05, 2016 12:10 pm    Post subject: Lost Text Reply with quote

Here is an example from the log, it is not getting logged nor is it getting displayed.

I have not found any commonality in the past based on color, or anything like that and it is very random from I see part of the line to no line at all.



^[[0m^[[40m^[[0m> ^[[0mYou have nothing you want to give away.^[[0m
^[[40m^[[0m> >
^[[0m^[[0m
^[[0;1;32;40m soon return whence I came.^[[0m^[[0m

Here is the same text that came through

^[[0m^[[40m^[[0m^[[0m^[[32m^[[40m^[[1mSkeletal warrior tells you: Master, I am not long for this world. I shalt^[[0m
^[[0;1;32;40m soon return whence I came.^[[0m^[[0m
Back to top
View user's profile Send private message
PowerGod



Joined: 04 Aug 2014
Posts: 339

PostPosted: Tue Jul 05, 2016 1:32 pm    Post subject: Reply with quote

When you see a broken line or a missing line, can you try to select that area, copy to the clipboard and past it on some text editor ?
If the text is there then it's just a color issue, maybe the text has the same color of your background. (Or maybe just try a different background color)

Looking at your example I see that the displayed line has a different color (32)... anyway I can't reproduce your issue, I tried your logs with a split and I can see every one of them...

You should also try to raise more the values of packet patch, to integers, and also there's the #CONFIG {COLOR PATCH} {ON|OFF} that could be make a difference.
Back to top
View user's profile Send private message
vision



Joined: 01 Feb 2014
Posts: 32

PostPosted: Tue Jul 05, 2016 5:22 pm    Post subject: Tintin Environment Reply with quote

What are you using for your Tintin environment including OS, version of Tintin, and terminal. I can try my scripts on that platform and see if I am having the same issue. I am not sure if it is a Mac issue.
Back to top
View user's profile Send private message
PowerGod



Joined: 04 Aug 2014
Posts: 339

PostPosted: Thu Jul 07, 2016 2:45 am    Post subject: Re: Tintin Environment Reply with quote

vision wrote:
What are you using for your Tintin environment including OS, version of Tintin, and terminal. I can try my scripts on that platform and see if I am having the same issue. I am not sure if it is a Mac issue.


tt++ 2.01.1 on Cygwin (terminal mintty set to xterm), Windows 8.1
Back to top
View user's profile Send private message
Scandum
Site Admin


Joined: 03 Dec 2004
Posts: 3770

PostPosted: Thu Aug 25, 2016 6:52 pm    Post subject: Reply with quote

Have you tried a higher value for packet patch?

No idea what might be causing this.
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    The TinTin++ message board Forum Index -> Script Help All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Get TinTin++ Mud Client at SourceForge.net. Fast, secure and Free Open Source software downloads Get TinTin++ Mud Client at SourceForge.net. Fast, secure and Free Open Source software downloads
TinTin++ Homepage

Powered by phpBB © 2001, 2002 phpBB Group