TinTin++ Mud Client The TinTin++ message board

 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
TinTin++ Mud Client

numpad doesn't work at all

 
Post new topic   Reply to topic    The TinTin++ message board Forum Index -> General Discussion
View previous topic :: View next topic  
Author Message
Segolas



Joined: 23 Feb 2006
Posts: 1

PostPosted: Thu Feb 23, 2006 11:23 am    Post subject: numpad doesn't work at all Reply with quote

Hello,

I'm on ubuntu (gnome) and I can't get numpad working. If I write:
"#config convert on" pressing the numpad keys returns the number instead of the key-code.

for example pressing "4" return just 4, while with bloc num off it returns the code of "left". But using it as "left2 my character moves pressing even left button.

ANy help?

thanx by now
Back to top
View user's profile Send private message
Scandum
Site Admin


Joined: 03 Dec 2004
Posts: 3770

PostPosted: Fri Feb 24, 2006 10:11 am    Post subject: Reply with quote

The problem is caused by either the terminal you are using, your operating system, or a combination of both. There are mutual problems on the Cygwin and Redhat platform, but for some reason nobody seems motivated/capable of solving the problem on those platforms.

My best guess would be trying a different terminal or asking Fedora to look into it. There may also be some configuration options for your terminal to enable the keypad.
Back to top
View user's profile Send private message Send e-mail
Roady



Joined: 28 Mar 2006
Posts: 25

PostPosted: Mon Jul 17, 2006 2:28 am    Post subject: Reply with quote

a console emulator called aterm seems to be doing the trick for me...

http://www.afterstep.org/aterm.php

you may need to get it from the multiverse repositories (its been a while since i installed) but its definately there.

TBH id rather use konsole (as im using kubuntu) but I havent had the time to sit down and dick around with keymaps...

aterm is a passable alternative
Back to top
View user's profile Send private message
CroX



Joined: 27 Sep 2007
Posts: 5

PostPosted: Thu Sep 27, 2007 10:07 am    Post subject: Reply with quote

I have this very same problem, with gnome-terminal. It doesn't seem to be a problem with any other terminal though. But that's just the thing .. I love the font of gnome-terminal and try as I might I have not been able to get that font in any other terminal.

Doesn anyone know of a fix to this problem?
Back to top
View user's profile Send private message
Scandum
Site Admin


Joined: 03 Dec 2004
Posts: 3770

PostPosted: Thu Sep 27, 2007 1:50 pm    Post subject: Reply with quote

You could try multi-gnome terminal:

http://multignometerm.sourceforge.net/index.shtml
Back to top
View user's profile Send private message Send e-mail
CroX



Joined: 27 Sep 2007
Posts: 5

PostPosted: Fri Sep 28, 2007 6:22 am    Post subject: Reply with quote

Scandum wrote:
You could try multi-gnome terminal:

http://multignometerm.sourceforge.net/index.shtml

I've tried it but it's so damn ugly I couldn't stand looking at it for hour after hour when playing. The gnome-terminal app is minimalistic, slick in its looks and also have that monospace font I can't seem to find anywhere else. Coupled with TinTin++ and my Lua-supportive proxy, I'd have my dream setup. Guess I'll keep on looking for a solution..

Thanks for the suggestion though!
Back to top
View user's profile Send private message
Scandum
Site Admin


Joined: 03 Dec 2004
Posts: 3770

PostPosted: Fri Sep 28, 2007 6:52 am    Post subject: Reply with quote

Pterm is another terminal worth trying. Have you had any luck with lua and the #run command?
Back to top
View user's profile Send private message Send e-mail
Artthou



Joined: 28 Feb 2005
Posts: 30

PostPosted: Sat Feb 02, 2008 1:14 am    Post subject: Reply with quote

aterm worked at getting me different codes for the numpad when numlock is turned off.

The only thing left now is the numpad enter key. Instead of functioning like the regular enter key, it sends \eOM

How can I make this a macro to just send enter after whatever is already typed?

Thanks in advance.
Back to top
View user's profile Send private message
Scandum
Site Admin


Joined: 03 Dec 2004
Posts: 3770

PostPosted: Sat Feb 02, 2008 7:14 am    Post subject: Reply with quote

You could try the following:

#macro {\eOM} {#showme \r;\n}
Back to top
View user's profile Send private message Send e-mail
Artthou



Joined: 28 Feb 2005
Posts: 30

PostPosted: Sat Feb 02, 2008 12:14 pm    Post subject: Reply with quote

That is close. It still ignores whatever is already typed. It may not be a macro that can help me if macros are oblivious to what has already be typed when the macro key is hit.

If there are no other suggestions, perhaps I could look at the code to see if a CONFIG setting could treat it exactly as it does the regular enter.

Thanks for the suggestions!
Back to top
View user's profile Send private message
Scandum
Site Admin


Joined: 03 Dec 2004
Posts: 3770

PostPosted: Sat Feb 02, 2008 12:29 pm    Post subject: Reply with quote

Doh, that indeed doesn't work.

I'll look into adding the #cursor enter option to simulate the enter key for the next release.
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    The TinTin++ message board Forum Index -> General Discussion All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Get TinTin++ Mud Client at SourceForge.net. Fast, secure and Free Open Source software downloads Get TinTin++ Mud Client at SourceForge.net. Fast, secure and Free Open Source software downloads
TinTin++ Homepage

Powered by phpBB © 2001, 2002 phpBB Group